Mage One Patch Bug – Kundenkonto Aktivierung defekt MO-68, Patch MO-69, Patch MO-70 und Patch MO-71

Wir sind nach einspielen der Patches Magen One Patches Patch MO-68, Patch MO-69 und Patch MO-70 auf ein Bug gestoßen.

Wie zu reproduzieren?

Einen neuen Kunden anlegen über das Frontend. Der Magento 1 Shop schickt die E-Mail an die E-Mail-Adresse des Kunden. Darin ist ein Link zum Anklicken.

Beim Klick auf den Link wird der Shop geöffnet, jedoch ein Fehler

mo-68 mo-69 mo-70

Das Mailtemplate sieht wie folgt aus

Beim Mailtempalte ist bei den Shops im Einsatz
<a href="{{store url="customer/account/confirm/" _query_id=$customer.id _query_key=$customer.confirmation _query_back_url=$back_url}}"> …. </a>

Link der generiert wird ist z.B. (Shopnamen rausgelöscht)

Live (ohne Patch)

/customer/account/confirm/?back_url=https%3A%2F%2Fwww.XXXX.de%2Fcustomer%2Faccount%2Findex%2F&id=XXXX&key=XXXX

Staging (mit Patch)

/customer/account/confirm/?back_url=https%3A%2F%2Fwww.XXXX.de%2Fcustomer%2Faccount%2Findex%2F&id=XXXX&key=XXXX

Auf Lösung warten

Mage One Support ist kontaktiert und warten nun auf die Rückmeldung. Stand jetzt würde das Live bringen des Patches den Onlineshop stark stören.

Update 12.05.2022 - Bug verifiziert

Mage One konnte den Bug reproduzieren und sind dabei den nun zu beheben. Ich vermute in den nächsten Stunden oder Tagen dürfte ein neuer Patch vorhanden sein.

Update 13.05.2022 - Bug gefixt - MO-72

Mage One hat ein neuen Patch rausgebracht, der den Bug fixen soll.

mehr Information zu Magento Onlineshops gibt es hier

mehr zu Magento Betreuung gibt es hier

Noch keine Kommentare bis jetzt

Einen Kommentar schreiben